image
image
image

Votre IP : 54.156.92.243
Dernier ajout : 17 novembre
Visiteurs connectés : 18

image Conception
Développé sous SPIP
Informations légales

image
image
Recherche image

Pratiques et Techniques de la Plaisance

image

Accueil du site > Forum technique > OpenCPN -forum- > Linux, Mac OS, etc ... -forum- > Cm93 impossible à charger. Je suis sous LinuxMint

Rubrique : Linux, Mac OS, etc ... -forum-

__________________________________________________________________________________________________________________

Cm93 impossible à charger. Je suis sous LinuxMintVersion imprimable de cet article Version imprimable

Publié Novembre 2015, (màj Novembre 2015) par : Bastide  image   

Copyright : Les articles sont la propriété de leurs auteurs et ne peuvent pas être reproduits en partie ou totalité sans leur accord
S'identifier pour s'abonner par mail

Bonjour,
Mon PC est sous LINUXMINTdepuis peu. _J’ai installé Open Cpn sans problème. Par contre je n’arrive pas à installer mon répertoire Cm93. Open Cpn ne le prend pas en compte, c’est comme si le répertoire était vide....
merci des infos sur la question
Cordialement
Bastide

UP


Répondre à cet article
(pour répondre à un message en particulier, voir plus bas dans le fil)

39 Messages de forum

__________________________________________________________________________________________________________________

__________________________________________________________________________________________________________________

  • 14 novembre 2015 21:02, par yoruk écrire     UP Animateur

    Par contre je n’arrive pas à installer mon répertoire Cm93

    Bonsoir,
    Je n’ai pas d’expérience sous Linux... Mais, et il faudrait le savoir, avez vous respecté les normes d’installation des cartes sous OpenCPN :

    Michel

    Répondre à ce message

    • 14 novembre 2015 21:14, par yoruk écrire     UP     Ce message répond à ... Animateur

      en complément

      • dans « dossiers des cartes » => depuis votre répertoire PC, choisir le dossier de cartes CM93 dans son ensemble
        • dans “Groupes de cartes” choisir le répertoire CM93

      Alors, à l’écran par un clic droit, sur la carte, on choisi l’option “Groupe de cartes” et on sélectionne ’toutes les cartes"... là vous devriez voir apparaître vos cartes

      Michel

      Répondre à ce message

      • Bonjour Yoruk et merci de ta réponse ;
        Il se trouve que je fais exactement cette manip.
        Le chemin du répertoire CM93 apparaît bien dans : « dossiers actifs des cartes » sous : /home/jm/CM93, puis dans toutes les cartes.« jm » étant un mon dossier perso qui est dur le bureau. Par contre avec le click droit je n’ai aucune action....
        Le répertoire CM93 est complet, il y a bien toutes les cartes que j’utilisais auparavant sous windows XP......Est ce la façon dont j’ai crée ce nouveau répertoire qui est en cause ??
        Autre chose, normalement le « point 0 » doit se trouver du côté du golfe de Guinée à 0.0N 0.0O, Ce qui n’est pas le cas sur la carte de fonds !!!
        Merci en tout cas
        Bien cordialement
        Bastide

        PNG

        Répondre à ce message

  • 16 novembre 2015 08:20, par Nevermind écrire     UP Animateur

    Bonjour,
    il faut mettre les cartes dans dossier cartes et non dans groupe de cartes.

    Jean paul

    PNG

    Répondre à ce message

  • Bonjour et merci Jean Paul, merci Michel de vos réponses.
     Malheureusement sous Linux ça ne se passe pas comme ça ! Michel, ta copie d’écran est un copie d’écran sous windows....
     Pour Jean Paul, j’ai aussi essayé de mettre les cartes dans « dossiers des cartes » comme je le faisais sous Windows XP (voir ma copie d’écran jointe), mais rien de mieux.
    Je suppose que le dossier CM93 que j’ai crée ne doit pas être conforme et lisible par la version Open Cpn sous Linux.
    Si quelqu’un connaît !
    Bien cordialement
    Bastide

    PNG

    Répondre à ce message

  • 16 novembre 2015 10:23, par Nevermind écrire     UP Animateur

    Dans le dossier des cartes, est ce que ces fichiers sont présent ?

    PNG

    Répondre à ce message

  • Une solution pour vérifier si ce sont bien les CM93 qui sont en cause. Je viens de mettre sous zip, un répertoire à extraire.

     
    Ce répertoire contient 3 cartes au format .KAP lisibles par OpenCPN

      • Répertoire : “demo_affichage_cartes”
        contenant 3 cartes du port de crotone :
      • z_Crotone_vieux-port_GE.kap
      • z_Crotone_vieux-port.kap
      • z_Crotone.kap

    En installant, une fois dézippé demo_affichage_cartes dans le dossier des cartes... on verra s’il elles sont lisibles. Si c’est le cas, c’est le dossier CM93 qui est vicié...

    Michel

    Répondre à ce message

  • Je n’ai aucune expérience de Linux, donc je vais peut-être dire une bêtise... Peut-être essayer le truc suivant, qui m’a dépanné une ou deux fois sur des PC que je bricolais : normalement Open CPN prend en charge les dossiers cartes, quel que soit le lieu de stockage, qui est, en général, le dossier « Documents ». Mais, dans certains cas, pour une raison que j’ignore, il ne les prenait en compte que s’ils étaient installés à la racine de C :/ (ou du disque contenant l’OS, quel que soit son nom)
    NB : c’était aussi le cas des versions de MaxSea « tombées du camion » ... à voir

    Répondre à ce message

  • j’utilise OCPN 4.0 et CM93 sur un PC sous Linux Mint sans aucun problème.
    Les cartes ne sont utilisables dans les groupes de cartes que si elles ont au préalable été activées.
    Avez-vous essayé de forcer la reconstruction de la base de données dans l’onglet : Dossiers des cartes ?

    Répondre à ce message

  • Merci Michel,
    J’ai dézippé ton fichier, je l’ai baptisé « Crotone », je l’ai placé dans « mes documents » j’ai ouvert Open Cpn, chargé les cartes qui apparaissent bien, voir les 2 captures d’écran, j’ai forcé la reconstruction, mais rien à faire pour les ouvrir, le logiciel doit avoir un bug quelque part....
    je ne sais plus quoi faire, est ce que j’ai la bonne version de OpenCpn, c’est la 4.0.0 que j’ai chargé comme suit :

    sudo apt-get install software-properties-common

    sudo add-apt-repository ppa:opencpn/opencpn

    sudo apt-get update

    sudo apt-get install opencpn

    Merci pour les aides
    Bien cordialement
    Bastide

    PNG

    Répondre à ce message

  • Suite avec la 2eme cature d’écran
    Bastide

    PNG

    Répondre à ce message

    • 17 novembre 2015 07:45, par yoruk écrire     UP     Ce message répond à ... Animateur

      Hé, hé...peur-être une lueur d’espoir... Sur ta dernière copie d’écran, celle du groupe de cartes, on voit bien dans l’onglet « toutes les cartes », apparaître les trois cartes que je t’ai passée. A partir de là, 2 hypothèses, à vérifier

      • Ces cartes n’apparaissent pas à l’écran, parce que très petites, OpenCPN ne les matérialise à l’écran qu’une fois centrée et avec un niveau d’échelle satisfaisant. Il arrive qu’il faille les activer en cliquant sur la touche bleu foncée de la barre des cartes. Alors , elle s’active, et la touche bleue passe au beu clair (enfin c’est ma vision de daltonien !!!), voir la copie d’écran jointe.
        • Ce qui aura pour effet l’affichage de cette carte raster, à sa meilleure échelle
        • Pour matérialiser ces cartes sur la carte, il faut cocher la case “Afficher la bordure des cartes” dans : “Outils => Affichage => Options propres à l’utilisateur => Afficher”
      • Si ta version Linux est bonne, et je ne saurais pas te dire ce qu’il en est, c’est bien tes CM93 qui sont en cause, puisqu’elles n’apparaissent pas dans l’onglet « Dossiers des cartes », ce qui est l’objet de ton fil
      • Enfin, la version 4.0.0 d’OpenCPN est parfaitement stable, je viens de l’utiiser, sous W7, pendant 6 mois, 2.000 milles, activée à temps complet

      Michel

      JPEG

      Répondre à ce message

  • Il peut effectivement y avoir un problème avec les groupes si tout n’est pas fait dans le bon ordre.

    je suggère d’oublier les groupes pour le moment et de repartir de zéro dans OCPN :
     effacer les groupes
     supprimer les dossiers actifs
    dans les 2 cas appuyer sur « appliquer »

     sélectionner le dossier CM93
     cliquer sur « appliquer »

    A ce niveau, logiquement, les cartes CM93 doivent s’afficher.
    Si elles ne s’affichent pas, fermer OCPN et le relancer. Si toujours rien, il faut alors consulter opencpn.log et voir ce que fait le programme avec l’ouverture des cartes.
    Eventuellement, vous pouvez l’afficher ici.

    Jean

    Répondre à ce message

  • Bonjour Michel, bonjour Jean,
    Merci de votre collaboration mais :
     bien que les cartes de Crotone apparaissent dans le dossier ad hoc, que je fais force l’installation, que je fais appliquer, etc...rien à faire. La barre bleue n’apparaît pas non plus dans la barre des échelles.....
     Pour Jean, j’ai tout effacé, relancé Open, sélectionné CM93, appliqué, forcé, etc.... et tjrs rien !!!
    Je pense devoir rechargé Open Cpn mais sans doute faut il d’abord le supprimer, et ça sous Linux je ne sais pas faire....
    Merci de vos conseils
    Cordialement
    Bastide

    Répondre à ce message

    • 17 novembre 2015 18:05, par yoruk écrire     UP     Ce message répond à ... Animateur

      C’est vrai que c’est agaçant...
      J’ai une ancienne machine qui tourne sur XP... Je vais tenter de monter Linux Mint.... Ne serait-ce que pour ne pas mourir idiot...
      Je vous tiendrais au courant

      Michel

      Répondre à ce message

    • pour effacer et (re) charger OpenCPN, le plus simple est d’utiliser le Gestionnaire de logiciels, situé dans le menu Système.

      Pouvez-vous déposer ici votre opencpn.log ?
      Pour l’obtenir dans OCPN, cliquer sur « A propos d’OpenCPN » et le copier dans le presse papier. Nous pourrons voir ce qu’il fait avec les fichiers des cartes.

      Jean

      Répondre à ce message

      • Bonjour Jean et merci !
        J’ai copié le fichier e, question, c’est un peu grand !! Je dois signaler autre chose : J’ai désinstallé Open Cpn, puis l’ai réinstallé, comme précédemment j’ai le même truc bizarre : Normalement quand j’étais sous XP, l’installation de Open Cpn une fois faite, situait un point initial à 0°N 0°E soit au sud du golfe guinée sur l’équateur et sur le méridien 0. Comme le montre la capture d’écran que j’envoie ci joint , ce point se trouve aux antipodes !
        Merci en tout cas à toi et aux autres pour le coup de main
        Cordialement
        Bastide :

        09:27:22 CET : 2015-11-18
        09:27:22 CET : ------- Starting OpenCPN -------
        09:27:22 CET : Version 4.0.0 Build 2015-01-08
        09:27:22 CET : wxWidgets version : wxWidgets 2.8.12
        09:27:22 CET : MemoryStatus : mem_total : 938 mb, mem_initial : 19 mb
        09:27:22 CET : SData_Locn is /usr/share/opencpn/
        09:27:22 CET : Using existing Config_File : /home/jm/.opencpn/opencpn.conf
        09:27:22 CET : Styles loading from /usr/share/opencpn/uidata/styles.xml
        09:27:22 CET : No styles found at : /home/jm/
        09:27:22 CET : No styles found at : /home/jm/.opencpn/
        09:27:22 CET : Detected display size : 361 mm
        09:27:22 CET : Detected display size : 361 mm
        09:27:22 CET : Setting Viewpoint Lat/Lon 0, 180
        09:27:22 CET : Setting Ownship Lat/Lon 0, 180
        09:27:22 CET : Loading navobjects from navobj.xml
        09:27:22 CET : Done loading navobjects
        09:27:22 CET : System default Language : fr_FR
        09:27:23 CET : Opencpn language set to : fr_FR
        09:27:23 CET : ChartSymbols loaded from /usr/share/opencpn/s57data/chartsymbols.xml
        09:27:23 CET : Using s57data in /usr/share/opencpn/s57data
        09:27:23 CET : Setting Viewpoint Lat/Lon 0, 180
        09:27:23 CET : Setting Ownship Lat/Lon 0, 180
        09:27:23 CET : Creating glChartCanvas
        09:27:23 CET : PlugInManager searching for PlugIns in location /usr/lib/opencpn
        09:27:23 CET : PlugInManager : Loading PlugIn : /usr/lib/opencpn/libgrib_pi.so
        09:27:23 CET : /usr/lib/opencpn/libgrib_pi.so
        API Version detected : 112
        PlugIn Version detected : 203
        09:27:23 CET : Opencpn language reload for : fr_FR
        09:27:23 CET : Loading catalog for : opencpn-grib_pi
        09:27:23 CET : Loading catalog for opencpn core.
        09:27:23 CET : PlugInManager : Loading PlugIn : /usr/lib/opencpn/libdashboard_pi.so
        09:27:23 CET : /usr/lib/opencpn/libdashboard_pi.so
        API Version detected : 106
        PlugIn Version detected : 102
        09:27:23 CET : Opencpn language reload for : fr_FR
        09:27:23 CET : Loading catalog for : opencpn-grib_pi
        09:27:23 CET : Loading catalog for : opencpn-dashboard_pi
        09:27:23 CET : Loading catalog for opencpn core.
        09:27:24 CET : ChartDB Cache policy : Application target is 459 MBytes
        09:27:24 CET : Loading chart db version : V018
        09:27:24 CET : Chartdb : Chart directory list follows
        09:27:24 CET : Chart directory #0 : /home/jm/CM93
        09:27:24 CET : GPS Watchdog Timeout is : 6 sec.
        09:27:24 CET : Loading World Chart Q=0 in 0 ms.
        09:27:24 CET : Background world map loaded from GSHHS datafiles found in : /usr/share/opencpn/gshhs/
        09:27:26 CET : ***GPS Watchdog timeout at Lat:0 Lon : 180

        PNG

        Répondre à ce message

  • 17 novembre 2015 18:32, par Nevermind écrire     UP Animateur

    Est ce que le plugin : ge2kap_pi.dll est présent dans le dossier plugins ?

    Mais cela ne sert que pour les cartes : .kap sinon pas de barres bleu !

    Jean Paul

    Répondre à ce message

  • 17 novembre 2015 18:41, par Nevermind écrire     UP Animateur

    Pour supprimer un programme sous linux :

    http://www.dailymotion.com/video/xf...

    Répondre à ce message

  • 18 novembre 2015 19:12, par Nevermind écrire     UP Animateur

    Sans ces fichiers les cartes ne peuvent pas être lu, ni ouverte.

    une copie avec le chemin pour trouver les fichiers sous PC

    PNG

    Répondre à ce message

  • 18 novembre 2015 19:35, par Nevermind écrire     UP Animateur

    Voici les fichiers à copier dans le répertoire des cartes en respectant le chemin

    Répondre à ce message

    • Bonsoir NEVERMIND

      Merci, c’est vous qui aviez raison ! :-)
      Dans mon DDE ou j’avais archivé mes CM93, et rechargé ensuite pour les lire avec OpenCpn sous Linux, ces fichiers étaient absents, pourquoi je ne sais pas mais, je viens de les retrouver sur une clé USB de sauvegarde de mon PC du bord et là en ouvrant le dossier CM93, j’ai bien trouvé les fichiers en question, et Open Cpn les ouvrent bien !!
      Tout est résolu, encore merci à toi et à tous les autres ....
      Seul reste un point à éclaircir, pourquoi Open Cpn s’ouvre avec le point de repère initial au milieu du Pacifique alors qu’auparavant il était dans le golfe de Guinée.. ? Mais cela ne gène en rien pour la suite .
      Bien cordialement
      Jean

      Répondre à ce message

Répondre à cet article

UP

Copyright et informations légales