image
image
image

Votre IP : 54.80.33.183
Dernier ajout : 19 novembre
Visiteurs connectés : 12

image Conception
Développé sous SPIP
Informations légales

image
image
Recherche image

Pratiques et Techniques de la Plaisance

image

Accueil du site > Forum technique > OpenCPN -forum- > Divers non classés OpenCPN -forum- > Opencpn recalcitrant ( cette foi)

Rubrique : Divers non classés OpenCPN -forum-

__________________________________________________________________________________________________________________

Opencpn recalcitrant ( cette foi)Version imprimable de cet article Version imprimable

Publié Décembre 2013, (màj Décembre 2013) par : thierry  image   

Copyright : Les articles sont la propriété de leurs auteurs et ne peuvent pas être reproduits en partie ou totalité sans leur accord
S'identifier pour s'abonner par mail

Utilisateur d’Opencpn depuis plus de huit ans , je l’ai déja installé sur des dizaines de PC de mes amis sous toutes les versions possibles de Windows. Ce logiciel fantastique marche dans tous les cas avec des efforts raisonnables .
J’ai trouvé un cas sur Windows 7 que je n’arrive pas à solutionner pour un ami .
Le logiciel dernière version est installé sur cette machine et marche parfaitement .Cependant j’utilise en navigation les fonctions propriétés des POI et les liens vers des images Google et vues aériennes ce qui rend ce logiciel equivalent à ceux à 1000 E.

Sur ce PC , tous les liens hypertexte des POi ouvrent le répertoire du logiciel et non pas les fichiers correspondants ( Jpeg, Pdf, texte, etc). Les liens identiques appelés depuis un logiciel d’office sur le même PC marchent parfaitement .
Ceci est vrai pour un fichier POI importé comme un lien créé en direct dans l’application .

Je connais assez bien Windows et ses subtilités et n’arrive pas à régler ce problème spécifique à ce PC W7 avec OpenCPN. L’installation est pourtant parfaitement « propre » .

Quelqu’un a t’il déjà vu ce cas ?

D’avance merci

UP


Répondre à cet article
(pour répondre à un message en particulier, voir plus bas dans le fil)

7 Messages de forum

__________________________________________________________________________________________________________________

__________________________________________________________________________________________________________________

  • 15 décembre 2013 15:39, par Robert écrire     UP

    La mémoire me revient avec 3 jours de retard :-P

    Je me souviens d’un bogue de ce genre dans OpenCPN qui provenait du mauvais traitement du caractère amperstamp « & » qui devrait être écrit « & »

    Pouvez vous joindre un fichier de ces liens qui ne marchent pas ?

    Répondre à ce message

    • 15 décembre 2013 17:01, par thierry écrire     UP     Ce message répond à ...  image

      bonjour

      Voila un exemple d’un fichier qui ne marche pas .Pour fonctionner il doit être installé directement sur la racine c : .
      Il marche par contre parfaitement avec OPEN CPN sur au moins 20 PC de l’association à laquelle j’appartiens .
      Ce qui est bizarre c’est que les liens importés dans open cpn vers les photos par exemple sont corrects et marchent après recopie dans n’importe quel programme office ( word, powerpoint, etc).
      ce PC est correctement paramétré pour tous types d’applications .
      Quand on a goutté à ces fonctions en navigation ( vue google, ports, photos), on ne sait plus s’en passer !!

      Répondre à ce message

      • 15 décembre 2013 17:58, par Robert écrire     UP     Ce message répond à ...

        Les fichiers ont l’air « normal ». Je ne vois qu’une chose (bien que peu probable) c’est que W7 sur ce PC soit configuré en notation numérique française (séparateur virgule à la place du séparateur point) avec des nombre qui sont attendus au format xyz,abc alors que ceux fournis sont au format xyz.abc ce qui peut perturber les coordonnées géodésiques et planter la lecture du fichier « gpx » par OpenCPN.

        Donc vérifier que Windows est bien au format nombres avec point décimal.

        Répondre à ce message

  • 15 décembre 2013 19:21, par thierry écrire     UP  image

    rebonsoir

    j’avais fait cet essai pour pouvoir utiliser marinePoi en générateur sur ce PC . Malheureusement pas d’effet .

    Ce qui est bizarre c’est d’ouvrir systématiquement le répertoire programme Opencpn avec des liens qui pointent sur un répertoire MarinePOI ?

    Merci pour vos réflexions sur un cas étrange . Je vais proposer a mon ami d’updater son windows pour W8 . Ca règlera peut être le PB car toutes les installations de programme sont à refaire !!

    Répondre à ce message

    • 15 décembre 2013 19:59, par Robert écrire     UP     Ce message répond à ...

      « Ce qui est bizarre c’est d’ouvrir systématiquement le répertoire programme Opencpn avec des liens qui pointent sur un répertoire MarinePOI ? »

      Si un programme appelle une lecture vers un répertoire cible qu’il ne peut pas trouver ou qu’il ne peut pas ouvrir, il est assez courant qu’il ouvre par défaut le répertoire de travail du programme lui-même. Donc pas de bizarrerie de ce côté là.

      La question est de comprendre pourquoi il n’arrive pas à ouvrir le répertoire cible.

      Serait-ce un de ces horribles problèmes de droits d’accès que génère parfois Windows dans ses versions récentes ? Donc tenter d’ouvrir OpenCPN avec des droits administrateurs (clic droit sur le raccourcis ...« ouvrir en administrateur »).

      Répondre à ce message

      • 16 décembre 2013 10:11, par thierry écrire     UP     Ce message répond à ...  image

        bonjour

        le mode administrateur que j’avais testé ne change pas la situation . Je viens même d’essayer de créer localement un fichier POI dans les documents et non plus sur la racine : même symptôme !!

        je vais essayer de le créer dans le répertoire programme Opencpn la ou il atterrit chaque fois ??

        et puis après je vais lâcher ce maudit PC !!

        Merci pour votre aide .

        Répondre à ce message

  • 31 mars 2014 17:22, par thierry écrire     UP  image

    merci de me répondre à nouveau .

    Mes amis me relancent pour résoudre leur « pb » car les beaux jours arrivent !!

    J’ai pris les liens dans le fichiers GPX et les ai essayé dans excel sur les mêmes machines ; ils s’ouvrent correctement dans une page de navigateur IE .

    Je vais essayer de vérifier du coté des programmes appelés par défaut pour les fichiers JPEG ou txt pointés par les liens .

    Répondre à ce message

Répondre à cet article

UP

Copyright et informations légales